summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 10:07:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:55 +0100
commitd024207e7bfaba0453e34de48510378ddd2dff4d (patch)
tree72ba82f0359e00a88e22ae44cc68696604a2070c /gnu/packages/cran.scm
parent70c0dbe73fa099cd7bebccb3bffba3dfe3c3137b (diff)
downloadguix-d024207e7bfaba0453e34de48510378ddd2dff4d.tar.gz
gnu: Add r-actcd.
* gnu/packages/cran.scm (r-actcd): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cb68994565..dd30ba3fbe 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17838,3 +17838,33 @@ or structured.  Q-matrix validation, item and model fit statistics, model
 comparison at test and item level and differential item functioning can also
 be conducted.  A graphical user interface is also provided.")
     (license license:gpl3)))
+
+(define-public r-actcd
+  (package
+    (name "r-actcd")
+    (version "1.2-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ACTCD" version))
+       (sha256
+        (base32
+         "0mzjxxr2zfdidw8ibh6w8mvpkw3q3nvngqi05g9ind26ckvk053p"))))
+    (properties `((upstream-name . "ACTCD")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-gdina" ,r-gdina)
+       ("r-r-methodss3" ,r-r-methodss3)))
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (home-page "https://cran.r-project.org/web/packages/ACTCD/")
+    (synopsis "Asymptotic classification theory for cognitive diagnosis")
+    (description
+     "This is a package supporting cluster analysis for cognitive diagnosis
+based on the Asymptotic Classification Theory (Chiu, Douglas & Li, 2009;
+@url{doi:10.1007/s11336-009-9125-0}).  Given the sample statistic of
+sum-scores, cluster analysis techniques can be used to classify examinees into
+latent classes based on their attribute patterns.  In addition to the
+algorithms used to classify data, three labeling approaches are proposed to
+label clusters so that examinees' attribute profiles can be obtained.")
+    (license license:gpl2+)))