summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-04 07:11:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-04 07:27:43 +0200
commitfadf5765c1a44c03144007737877f6d3abb8332a (patch)
tree7998a2bb944027a4bddc09759ad4c341b72dedc7 /gnu/packages/cran.scm
parent8a3766e1d37bf8aa411a19e29d57c4e0fb6fc30d (diff)
downloadguix-fadf5765c1a44c03144007737877f6d3abb8332a.tar.gz
gnu: Add r-dtplyr.
* gnu/packages/cran.scm (r-dtplyr): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 679387e473..b92a8258aa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7176,6 +7176,41 @@ data.frame and more.  This is useful for decision trees, machine learning,
 finance, conversion from and to JSON, and many other applications.")
     (license license:gpl2+)))
 
+(define-public r-dtplyr
+  (package
+    (name "r-dtplyr")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "dtplyr" version))
+       (sha256
+        (base32
+         "0cn7vxn92dcxrnabccla6ppf5x7pxfz6pjlmamp0imfphmr1ns4r"))))
+    (properties `((upstream-name . "dtplyr")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-crayon" ,r-crayon)
+       ("r-data-table" ,r-data-table)
+       ("r-dplyr" ,r-dplyr)
+       ("r-ellipsis" ,r-ellipsis)
+       ("r-glue" ,r-glue)
+       ("r-lifecycle" ,r-lifecycle)
+       ("r-rlang" ,r-rlang)
+       ("r-tibble" ,r-tibble)
+       ("r-tidyselect" ,r-tidyselect)
+       ("r-vctrs" ,r-vctrs)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/tidyverse/dtplyr")
+    (synopsis "Data Table back-end for dplyr")
+    (description
+     "This package provides a @code{data.table} backend for @code{dplyr}.  The
+goal of @code{dtplyr} is to allow you to write @code{dplyr} code that is
+automatically translated to the equivalent, but usually much faster,
+@code{data.table} code.")
+    (license license:expat)))
+
 (define-public r-collapsibletree
   (package
     (name "r-collapsibletree")