summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-08 23:29:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-08 23:31:56 +0100
commitbe815dbdda155e1e920667a1c34bf264cb20f5b3 (patch)
tree5b0fa9ff47a994288043c799b7ef666cd6cf4199 /gnu/packages/cran.scm
parentd10b0952ce6be1c4f172b21622184e59bb3e1020 (diff)
downloadguix-be815dbdda155e1e920667a1c34bf264cb20f5b3.tar.gz
gnu: Add r-smoother.
* gnu/packages/cran.scm (r-smoother): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 81b791d346..4e3a036044 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3169,3 +3169,26 @@ regression and information measures are implemented.")
     ;; The DESCRIPTION file erroneously states that GPL version 2.1 or
     ;; later can be used.
     (license license:gpl2+)))
+
+(define-public r-smoother
+  (package
+    (name "r-smoother")
+    (version "1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "smoother" version))
+       (sha256
+        (base32
+         "0nqr1bvlr5bnasqg74zmknjjl4x28kla9h5cxpga3kq5z215pdci"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ttr" ,r-ttr)))
+    (home-page "http://cran.r-project.org/web/packages/smoother")
+    (synopsis "Functions relating to the smoothing of numerical data")
+    (description
+     "This package provides a collection of methods for smoothing numerical
+data, commencing with a port of the Matlab gaussian window smoothing function.
+In addition, several functions typically used in smoothing of financial data
+are included.")
+    (license license:gpl2)))