summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:57 +0200
commit9899f472e6bef9d6e37afed81c1ec995fc643557 (patch)
tree42fb45f5a14a384cddfd86bd034ebe96c769a8f0 /gnu/packages/cran.scm
parent96b966a35924d19f28e64a2307911dd472e5d979 (diff)
downloadguix-9899f472e6bef9d6e37afed81c1ec995fc643557.tar.gz
gnu: Add r-cvauc.
* gnu/packages/cran.scm (r-cvauc): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7205d3d748..04d5c16b80 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9682,6 +9682,33 @@ and coverage methods to tune the choice of threshold.")
 ggplot2 package.")
     (license license:gpl3)))
 
+(define-public r-cvauc
+  (package
+    (name "r-cvauc")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "cvAUC" version))
+       (sha256
+        (base32
+         "13bk97l5nn97h85iz93zxazhr63n21nwyrpnl856as9qp59yvn64"))))
+    (properties `((upstream-name . "cvAUC")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-data-table" ,r-data-table)
+       ("r-rocr" ,r-rocr)))
+    (home-page "https://github.com/ledell/cvAUC")
+    (synopsis "Cross-validated area under the ROC curve confidence intervals")
+    (description
+     "This package contains various tools for working with and evaluating
+cross-validated area under the ROC curve (AUC) estimators.  The primary
+functions of the package are @code{ci.cvAUC} and @code{ci.pooled.cvAUC}, which
+report cross-validated AUC and compute confidence intervals for
+cross-validated AUC estimates based on influence curves for i.i.d. and pooled
+repeated measures data, respectively.")
+    (license license:asl2.0)))
+
 (define-public r-mosaiccore
   (package
     (name "r-mosaiccore")