summary refs log tree commit diff
path: root/gnu/packages/crates-gtk.scm
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-10-23 23:21:16 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-10-24 14:39:43 +0300
commitb39e6508b794e2c287dc86fba9830796b754db93 (patch)
tree7a86882a6a82e3312aa5813da7d04260213dc5dd /gnu/packages/crates-gtk.scm
parenta4454aa4d2870e9c5e7cb4a14543de86dbcf9f85 (diff)
downloadguix-b39e6508b794e2c287dc86fba9830796b754db93.tar.gz
gnu: Add rust-gstreamer-base-0.18.
* gnu/packages/crates-gtk.scm (rust-gstreamer-base-0.18): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Change-Id: I6c96a0d5b59c4cddef5d874e29b23afb29606063
Diffstat (limited to 'gnu/packages/crates-gtk.scm')
-rw-r--r--gnu/packages/crates-gtk.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 92e4ea9322..41233ab1d5 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1755,6 +1755,34 @@
     (description "Rust bindings for GStreamer.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-gstreamer-base-0.18
+  (package
+    (name "rust-gstreamer-base")
+    (version "0.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gstreamer-base" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0gw6sr75h01y3j6lpxhc7p1frvkba9a4imyyb2ppqh42cprkakr2"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f  ; https://github.com/gtk-rs/gtk3-rs/issues/768
+       #:cargo-inputs (("rust-bitflags" ,rust-bitflags-1)
+                       ("rust-cfg-if" ,rust-cfg-if-1)
+                       ("rust-glib" ,rust-glib-0.15)
+                       ("rust-gstreamer" ,rust-gstreamer-0.18)
+                       ("rust-gstreamer-base-sys" ,rust-gstreamer-base-sys-0.18)
+                       ("rust-libc" ,rust-libc-0.2))
+       #:cargo-development-inputs (("rust-gir-format-check" ,rust-gir-format-check-0.1))))
+    (native-inputs (list pkg-config))
+    (inputs (list glib gstreamer))
+    (home-page "https://gstreamer.freedesktop.org")
+    (synopsis "Rust bindings for GStreamer Base library")
+    (description "Rust bindings for GStreamer Base library.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gstreamer-base-sys-0.18
   (package
     (name "rust-gstreamer-base-sys")