summary refs log tree commit diff
path: root/gnu/packages/crates-gtk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-02 19:32:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:16 +0300
commitce2002911cd1debf38d7b898f23eb1378ac83f22 (patch)
tree18b163d84bc0e9727a65767c0c2d9caf295a72ea /gnu/packages/crates-gtk.scm
parent0766da728bd21179521a4ad028a1c319376cb895 (diff)
downloadguix-ce2002911cd1debf38d7b898f23eb1378ac83f22.tar.gz
gnu: Add rust-gobject-sys-0.17.
* gnu/packages/crates-gtk.scm (rust-gobject-sys-0.17): New variable.
(rust-gobject-sys-0.15): Inherit from rust-gobject-sys-0.17.
Diffstat (limited to 'gnu/packages/crates-gtk.scm')
-rw-r--r--gnu/packages/crates-gtk.scm44
1 files changed, 34 insertions, 10 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index a27ea1bbd6..1bd61d7f19 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1462,8 +1462,41 @@
        (("rust-shell-words" ,rust-shell-words-0.1)
         ("rust-tempfile" ,rust-tempfile-3))))))
 
+(define-public rust-gobject-sys-0.17
+  (package
+    (name "rust-gobject-sys")
+    (version "0.17.10")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "gobject-sys" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ql0pcab6dxjapiglxcjaavbbh1sznyc2wj5q273b9j0fwqw6d6d"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(;; XXX: Tests are sensitive to the version of glib, even though
+       ;; the library supports a wide range.  Skip for now.
+       #:tests? #f
+       #:cargo-inputs
+       (("rust-glib-sys" ,rust-glib-sys-0.17)
+        ("rust-libc" ,rust-libc-0.2)
+        ("rust-system-deps" ,rust-system-deps-6))
+       #:cargo-development-inputs
+       (("rust-shell-words" ,rust-shell-words-1)
+        ("rust-tempfile" ,rust-tempfile-3))))
+    (native-inputs
+     (list pkg-config))
+    (inputs
+     (list glib))
+    (home-page "https://gtk-rs.org/")
+    (synopsis "FFI bindings to libgobject-2.0")
+    (description "This package provides FFI bindings to libgobject-2.0.")
+    (license license:expat)))
+
 (define-public rust-gobject-sys-0.15
   (package
+    (inherit rust-gobject-sys-0.17)
     (name "rust-gobject-sys")
     (version "0.15.10")
     (source
@@ -1473,7 +1506,6 @@
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "02hyilvpi4hw4gr03z2plsbf1zicsfs5l0xxadqx3v3b4i2cwmqd"))))
-    (build-system cargo-build-system)
     (arguments
      `(;; FIXME: Constant value mismatch for G_TYPE_FUNDAMENTAL_MAX
        ;; Rust: "255"
@@ -1485,15 +1517,7 @@
         ("rust-system-deps" ,rust-system-deps-6))
        #:cargo-development-inputs
        (("rust-shell-words" ,rust-shell-words-1)
-        ("rust-tempfile" ,rust-tempfile-3))))
-    (native-inputs
-     (list pkg-config))
-    (inputs
-     (list glib))
-    (home-page "https://gtk-rs.org/")
-    (synopsis "FFI bindings to libgobject-2.0")
-    (description "This package provides FFI bindings to libgobject-2.0.")
-    (license license:expat)))
+        ("rust-tempfile" ,rust-tempfile-3))))))
 
 (define-public rust-gobject-sys-0.14
   (package