summary refs log tree commit diff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-21 11:29:49 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:42:08 +0530
commitc2b43329a1fdc92ac8edb8b6b17dfa865e925bd2 (patch)
tree7b70b6a96850f9f63131db5665359b3749395057 /gnu/packages/crates-io.scm
parent722c00d1109cd06418a90d36f6a729c3ef9ace90 (diff)
downloadguix-c2b43329a1fdc92ac8edb8b6b17dfa865e925bd2.tar.gz
gnu: Add rust-path-clean-0.1.
* gnu/packages/crates-io.scm (rust-path-clean-0.1): New variable.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c377870532..1c22e12575 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17969,6 +17969,25 @@ and would-block I/O operations.")
      "Implementation detail of the paste crate.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-path-clean-0.1
+  (package
+    (name "rust-path-clean")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "path-clean" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1pcgqxw0mgg3ha5hi5xkjhyjf488bw5rw1g3qlr9awbq4szh3fpc"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/danreeves/path-clean")
+    (synopsis "Rust implementation of cleanname or path.Clean")
+    (description "This package provides a Rust implementation of cleanname or
+path.Clean.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-pbkdf2-0.4
   (package
     (name "rust-pbkdf2")