summary refs log tree commit diff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-24 10:49:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:30 +0200
commit80fca36e8ec5036628367c777eb962bb85df2cc4 (patch)
treebe4ead73bb9855b05fa2df5323702555de51a8c3 /gnu/packages/crates-web.scm
parent040880cc04329f104fa6013669d20fa3a7a97d5f (diff)
downloadguix-80fca36e8ec5036628367c777eb962bb85df2cc4.tar.gz
gnu: rust-httparse-1: Move to (gnu packages crates-web).
* gnu/packages/crates-io.scm (rust-httparse-1): Move from here ...
* gnu/packages/crates-web.scm: ... to here.

Change-Id: I570aa3965faf52cce7cdea231512dd33e7d7bd4c
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index cc3a2ddd0e..b921598f8a 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2065,6 +2065,28 @@ HTTP request or response body.")
      "This package provides common types for HTTP operations.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-httparse-1
+  (package
+    (name "rust-httparse")
+    (version "1.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "httparse" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "010rrfahm1jss3p022fqf3j3jmm72vhn4iqhykahb9ynpaag75yq"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-development-inputs
+       (("rust-criterion" ,rust-criterion-0.3))))
+    (home-page "https://github.com/seanmonstar/httparse")
+    (synopsis "Zero-copy HTTP/1.x parser")
+    (description
+     "This package provides a tiny, safe, speedy, zero-copy HTTP/1.x parser.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-hyper-0.14
   (package
     (name "rust-hyper")