summary refs log tree commit diff
path: root/gnu/packages/cross-base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-04 18:07:26 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-04 18:07:26 +0200
commit8d866b96f75cd6fc8006721fdcb0c2ed7da6c842 (patch)
tree143bceb117f6b0cb55625212c4a7d46ef3fb1c89 /gnu/packages/cross-base.scm
parentde4ac325275867a626be90540c8890995d0458db (diff)
downloadguix-8d866b96f75cd6fc8006721fdcb0c2ed7da6c842.tar.gz
gnu: Switch to GCC 4.9 as the default cross-compiler.
* gnu/packages/cross-base.scm: Replace all occurrences of "gcc-4.8" with
  "gcc-4.9".
Diffstat (limited to 'gnu/packages/cross-base.scm')
-rw-r--r--gnu/packages/cross-base.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 9a459400e8..abe87da25c 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -86,7 +86,7 @@ may be either a libc package or #f.)"
   ;; Set the current target system so that 'glibc-dynamic-linker' returns the
   ;; right name.
   (parameterize ((%current-target-system target))
-    (substitute-keyword-arguments (package-arguments gcc-4.8)
+    (substitute-keyword-arguments (package-arguments gcc-4.9)
       ((#:configure-flags flags)
        `(append (list ,(string-append "--target=" target)
                       ,@(if libc
@@ -194,14 +194,14 @@ may be either a libc package or #f.)"
   "Return a cross-compiler for TARGET, where TARGET is a GNU triplet.  Use
 XBINUTILS as the associated cross-Binutils.  If LIBC is false, then build a
 GCC that does not target a libc; otherwise, target that libc."
-  (package (inherit gcc-4.8)
+  (package (inherit gcc-4.9)
     (name (string-append "gcc-cross-"
                          (if libc "" "sans-libc-")
                          target))
-    (source (origin (inherit (package-source gcc-4.8))
+    (source (origin (inherit (package-source gcc-4.9))
               (patches
                (append
-                (origin-patches (package-source gcc-4.8))
+                (origin-patches (package-source gcc-4.9))
                 (cons (search-patch "gcc-cross-environment-variables.patch")
                       (cross-gcc-patches target))))))
 
@@ -231,7 +231,7 @@ GCC that does not target a libc; otherwise, target that libc."
        ("libc-native" ,@(assoc-ref %final-inputs "libc"))
 
        ;; Remaining inputs.
-       ,@(let ((inputs (append (package-inputs gcc-4.8)
+       ,@(let ((inputs (append (package-inputs gcc-4.9)
                                (alist-delete "libc" %final-inputs))))
            (if libc
                `(("libc" ,libc)