summary refs log tree commit diff
path: root/gnu/packages/cross-base.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-05 16:45:18 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-11 19:22:27 +0200
commit1c4268e4147063355f41b7958bdb61bef96f58c0 (patch)
tree642c81c25fe83e51da8c4a3040017e87601b4cc5 /gnu/packages/cross-base.scm
parentad3bbeadb46accce9c744f45cf079426b7e9a318 (diff)
downloadguix-1c4268e4147063355f41b7958bdb61bef96f58c0.tar.gz
gnu: cross-libc: Add patch to allow 'gettyent' reading store file names.
* gnu/packages/patches/glibc-hurd-gettyent.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/cross-base.scm (cross-libc): Add it in 'patch-libc/hurd' phase
when 'hurd-target?' is true.
Diffstat (limited to 'gnu/packages/cross-base.scm')
-rw-r--r--gnu/packages/cross-base.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index c21390767f..9b4aa103da 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -522,11 +522,15 @@ and the cross tool chain."
                                 (string-append out "/lib/libc.so.0.3"
                                                " libmachuser.so libhurduser.so"))))
                            #t))
+                       ;; TODO: move to glibc in the next rebuild cycle
                        (add-after 'unpack 'patch-libc/hurd
                          (lambda* (#:key inputs #:allow-other-keys)
-                           (let ((patch (assoc-ref inputs
-                                                   "hurd-mach-print.patch")))
-                             (invoke "patch" "-p1" "--force" "-i" patch)))))
+                           (for-each
+                            (lambda (name)
+                              (let ((patch (assoc-ref inputs name)))
+                                (invoke "patch" "-p1" "--force" "-i" patch)))
+                            '("hurd-mach-print.patch"
+                              "hurd-gettyent.patch")))))
                      '())))))
 
         ;; Shadow the native "kernel-headers" because glibc's recipe expects the
@@ -543,8 +547,11 @@ and the cross tool chain."
                                `(("cross-mig"
                                   ,@(assoc-ref (package-native-inputs xheaders)
                                                "cross-mig"))
+                                 ;; TODO: move to glibc in the next rebuild cycle
                                  ("hurd-mach-print.patch"
-                                  ,@(search-patches "glibc-hurd-mach-print.patch")))
+                                  ,@(search-patches "glibc-hurd-mach-print.patch"))
+                                 ("hurd-gettyent.patch"
+                                  ,@(search-patches "glibc-hurd-gettyent.patch")))
                                '())
                          ,@(package-inputs libc)  ;FIXME: static-bash
                          ,@(package-native-inputs libc))))))