summary refs log tree commit diff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-31 00:03:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-31 00:24:59 +0100
commitf92ebd57e4edeae2cbae85e978e23655f8733f16 (patch)
tree2311de7fcf6ca55c6817a60719ebca8b448a1b82 /gnu/packages/crypto.scm
parent022ad24c4177c9bc29c3a751db544bc12d0804f4 (diff)
downloadguix-f92ebd57e4edeae2cbae85e978e23655f8733f16.tar.gz
gnu: crypto++: Create versioned shared library links.
This fixes the build of dependents like amule.

* gnu/packages/crypto.scm (crypto++)[arguments]: Add an
‘install-shared-library-links’ phase.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index db39166d45..dd49c12e5b 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -633,6 +633,16 @@ data on your platform, so the seed itself will be as random as possible.
            (lambda _
              ;; By default, only the static library is built.
              (invoke "make" "shared")))
+         (add-after 'install 'install-shared-library-links
+           ;; By default, only .so and .so.x.y.z are installed.
+           ;; Create all the ‘intermediates’ expected by dependent packages.
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (lib (string-append out "/lib")))
+               (with-directory-excursion lib
+                 (symlink "libcryptopp.so.8.0.0" "libcryptopp.so.8.0")
+                 (symlink "libcryptopp.so.8.0.0" "libcryptopp.so.8")
+                 #t))))
          (add-after 'install 'install-pkg-config
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))