summary refs log tree commit diff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-01-11 12:33:41 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-01-11 19:48:00 +0100
commite0fa641380cf276eee199a17904c63a7e8e5ea04 (patch)
tree073ccb79d8a8b37f935e8860713eaaf724fce0f8 /gnu/packages/crypto.scm
parent362fba83ddefd706641924f5e4c7b5681eb8e216 (diff)
downloadguix-e0fa641380cf276eee199a17904c63a7e8e5ea04.tar.gz
gnu: opendht: Use jsoncpp and restbed.
* gnu/packages/crypto.scm (opendht): Move definition to networking.scm.
* gnu/packages/networking.scm (opendht)[inputs]: Add jsoncpp and restbed.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 56f909ed2f..d72162d6a8 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -166,43 +166,6 @@ OpenBSD tool of the same name.")
                                           "See base64.c in the distribution for
                                            the license from IBM.")))))
 
-(define-public opendht
-  (package
-    (name "opendht")
-    (version "1.8.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/savoirfairelinux/opendht.git")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0vninb5mak27wigajslyvr05vq7wbrwqhbr4wzl2nmqcb20wmlq2"))))
-    (build-system gnu-build-system)
-    (inputs
-     `(("gnutls" ,gnutls)
-       ("nettle" ,nettle)
-       ("readline" ,readline)
-       ("argon2" ,argon2)))
-    (propagated-inputs
-     `(("msgpack" ,msgpack)))           ;included in several installed headers
-    (native-inputs
-     `(("autoconf" ,autoconf)
-       ("pkg-config" ,pkg-config)
-       ("automake" ,automake)
-       ("libtool" ,libtool)))
-    (arguments
-     `(#:configure-flags '("--disable-tools"
-                           "--disable-python"
-                           "--with-argon2")))
-    (home-page "https://github.com/savoirfairelinux/opendht/")
-    (synopsis "Distributed Hash Table (DHT) library")
-    (description "OpenDHT is a Distributed Hash Table (DHT) library.  It may
-be used to manage peer-to-peer network connections as needed for real time
-communication.")
-    (license license:gpl3+)))
-
 (define-public encfs
   (package
     (name "encfs")