summary refs log tree commit diff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-11 15:57:45 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-11 15:59:20 +0100
commitf7f55db8f6d049225898d4ebcd7bc1d53623f32d (patch)
treeb21e1cb4f68a1f4095c1f0978290cca27e29816c /gnu/packages/crypto.scm
parentca3476cd6c5a048a67ac92fc05ca77ded5a1b7f0 (diff)
downloadguix-f7f55db8f6d049225898d4ebcd7bc1d53623f32d.tar.gz
gnu: Move sparsehash to datastructures module.
* gnu/packages/crypto.scm (sparsehash): Move variable to...
* gnu/packages/datastructures.scm: ...new file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 08af95f8eb..d4742ca0e4 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -43,28 +43,3 @@
 communication, encryption, decryption, signatures, etc.")
     (license isc)
     (home-page "http://libsodium.org")))
-
-(define-public sparsehash
-  (package
-    (name "sparsehash")
-    (version "2.0.3")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/sparsehash/sparsehash/"
-                                  "archive/sparsehash-" version ".tar.gz"))
-              (sha256
-               (base32
-                "133szz0ldwch0kd91l0sa57qsnl020njn622szd9cxrjqyjqds85"))))
-    (build-system gnu-build-system)
-    (synopsis "Memory-efficient hashtable implementations")
-    (description
-     "This library contains several hash-map implementations, similar in API
-to SGI's @code{hash_map} class, but with different performance
-characteristics.  @code{sparse_hash_map} uses very little space overhead, 1-2
-bits per entry.  @code{dense_hash_map} is very fast, particulary on lookup.
-@code{sparse_hash_set} and @code{dense_hash_set} are the set versions of these
-routines.  All these implementation use a hashtable with internal quadratic
-probing.  This method is space-efficient -- there is no pointer overhead --
-and time-efficient for good hash functions.")
-    (home-page "https://github.com/sparsehash/sparsehash")
-    (license bsd-3)))