summary refs log tree commit diff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:20:03 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:37:07 -0400
commitebf85c3c39f774559ebb35634e79ec2aaab196ad (patch)
tree6b8cef4754db781d2dcf44439a7f911f2791fb52 /gnu/packages/cups.scm
parentd8de115d3525b3e9f4cacaa521c38ec13e2e819d (diff)
downloadguix-ebf85c3c39f774559ebb35634e79ec2aaab196ad.tar.gz
gnu: hplip: Update to 3.23.3.
* gnu/packages/cups.scm (hplip): Update to 3.23.3.
[arguments]: Remove the fix-build-with-python-3.8 phase.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 82eb3cb1b4..133d7debf4 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -501,14 +501,14 @@ should only be used as part of the Guix cups-pk-helper service.")
 (define-public hplip
   (package
     (name "hplip")
-    (version "3.22.10")
+    (version "3.23.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/hplip/hplip/" version
                                   "/hplip-" version ".tar.gz"))
               (sha256
                (base32
-                "09366v0x10l35bkda6s5ysh64qdf24givn2gxlyidr2kdcpkyg2k"))
+                "1dh7gqhzv03a6j1kbkiaksy9a752k90xwqi5x0hqvn5ilac0l9p4"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -612,17 +612,6 @@ should only be used as part of the Guix cups-pk-helper service.")
                    (string-append "rulessystemdir = " out "/lib/systemd/system"))
                   (("/etc/sane.d")
                    (string-append out "/etc/sane.d"))))))
-          (add-before 'configure 'fix-build-with-python-3.8
-            (lambda* (#:key inputs #:allow-other-keys)
-              (let ((python (assoc-ref inputs "python")))
-                ;; XXX: The configure script looks for Python headers in the
-                ;; wrong places as of version 3.20.3.  Help it by adding the
-                ;; include directory on C_INCLUDE_PATH.
-                (when python
-                  (setenv "C_INCLUDE_PATH"
-                          (string-append python "/include/python"
-                                         (python:python-version python)
-                                         ":" (getenv "C_INCLUDE_PATH")))))))
           (add-after 'install 'install-models-dat
             (lambda* (#:key outputs #:allow-other-keys)
               (install-file "data/models/models.dat"