summary refs log tree commit diff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-18 15:55:10 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-18 16:01:30 -0500
commit185e8ac8cc52669fe1a94954f2a944abd3dde2f5 (patch)
tree7b3dad42429f21f0d0090f564eeddf7791a85784 /gnu/packages/cups.scm
parentf3329764e2d3ffee7f0d177d33820c93e720b82e (diff)
downloadguix-185e8ac8cc52669fe1a94954f2a944abd3dde2f5.tar.gz
gnu: Add hplip-next.
* gnu/packages/cups.scm (hplip-next): New variable.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index c729363fe8..259805b98a 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -7,7 +7,7 @@
 ;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -696,6 +696,33 @@ should only be used as part of the Guix cups-pk-helper service.")
     (native-inputs
      (list perl pkg-config))))
 
+;;; TODO: Integrate in base hplip package on core-updates.
+(define-public hplip-next
+  (package
+    (inherit hplip)
+    (name "hplip")
+    (version "3.21.10")
+    (source (origin
+              (inherit (package-source hplip))
+              (uri (string-append "mirror://sourceforge/hplip/hplip/" version
+                                  "/hplip-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0q3adcp8iygravp4bq4gw14jk20c5rhnawj1333qyw8yvlghw8yy"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments hplip)
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (add-after 'unpack 'fix-more-hard-coded-file-names
+              (lambda* (#:key outputs #:allow-other-keys)
+                ;; Set the encoding to ISO-8859-1, as not all the files are
+                ;; readable as UTF-8.
+                (with-fluids ((%default-port-encoding "ISO-8859-1"))
+                  (substitute* (find-files ".")
+                    (("/etc/hp/hplip.conf")
+                     (string-append (assoc-ref outputs "out")
+                                    "/etc/hp/hplip.conf"))))))))))))
+
 (define-public hplip-minimal
   (package/inherit hplip
     (name "hplip-minimal")