summary refs log tree commit diff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-07 23:13:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-07 23:16:02 +0200
commitb44b1f08f6945ea8370746cfdadb44c7dea9ea3e (patch)
tree2a47d57828cc946766e4342b53f2a96c1a7437b3 /gnu/packages/cups.scm
parentea68b3f6527cf4a02c554cf3f6f446e30f4940f6 (diff)
downloadguix-b44b1f08f6945ea8370746cfdadb44c7dea9ea3e.tar.gz
gnu: hplip: Remove bundled non-free blobs.
This fixes <https://bugs.gnu.org/32184>.

* gnu/packages/cups.scm (hplip)[source]: Add patch. Update snippet to
remove non-free code and binary blobs.
* gnu/packages/patches/hplip-remove-imageprocessor.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 4259648c69..04a533de02 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -405,9 +405,13 @@ device-specific programs to convert and print many types of files.")
                (base32
                 "0g3q5mm2crjyc1z4z6gv4lam6sc5d3diz704djrnpqadk4q3h290"))
               (modules '((guix build utils)))
+              (patches (search-patches "hplip-remove-imageprocessor.patch"))
               (snippet
-               ;; Fix type mismatch.
                '(begin
+                  ;; Delete non-free blobs
+                  (for-each delete-file (find-files "." "\\.so$"))
+                  (delete-file "prnt/hpcups/ImageProcessor.h")
+                  ;; Fix type mismatch.
                   (substitute* "prnt/hpcups/genPCLm.cpp"
                     (("boolean") "bool"))
                   #t))))