summary refs log tree commit diff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-23 15:24:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-23 15:31:36 +0100
commit14251e30c44f7d7b3894ff5dcdad05980bb84109 (patch)
treef9c3b06719ba65667be75e61810910f7aed38387 /gnu/packages/curl.scm
parentb881dc6d9825bc80e4714f4aec74d8e862de2976 (diff)
downloadguix-14251e30c44f7d7b3894ff5dcdad05980bb84109.tar.gz
gnu: curl: Update replacement to 7.52.1 [fixes CVE-2016-{9586,9594}].
* gnu/packages/curl.scm (curl)[replacement]: Update to 7.52.1.
[home-page]: Use HTTPS.
(curl-7.51.0): Replace with ...
(curl-7.52.1): ... this.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 790f542a52..7329d870de 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -40,7 +40,7 @@
 (define-public curl
   (package
    (name "curl")
-   (replacement curl-7.51.0)
+   (replacement curl-7.52.1)
    (version "7.50.3")
    (source (origin
             (method url-fetch)
@@ -119,17 +119,17 @@ authentication (Basic, Digest, NTLM, Negotiate, kerberos...), proxy
 tunneling, and so on.")
    (license (license:non-copyleft "file://COPYING"
                                   "See COPYING in the distribution."))
-   (home-page "http://curl.haxx.se/")))
+   (home-page "https://curl.haxx.se/")))
 
-(define curl-7.51.0
+(define curl-7.52.1
   (package
     (inherit curl)
     (source
-      (let ((version "7.51.0"))
+      (let ((version "7.52.1"))
         (origin
           (method url-fetch)
           (uri (string-append "https://curl.haxx.se/download/curl-"
                               version ".tar.lzma"))
           (sha256
            (base32
-            "0605f28m2kxjcxrcfcv1ja353gv167lwyxjc3xizqbwppdmmzvwy")))))))
+            "0r937wplchjxifxqqcjxd9rzp6l9rqqdfjn41x1y4djrh95nsa24")))))))