summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-18 16:42:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-26 16:15:46 +0200
commit76656a23bf69216cf3ca4af8f09dd9ba82c75ffb (patch)
tree7047cc27b18438ec2da0e2201d303777e2b16fdc /gnu/packages/databases.scm
parent5bac1466292e0f8d845665e72834ec67eda88951 (diff)
downloadguix-76656a23bf69216cf3ca4af8f09dd9ba82c75ffb.tar.gz
gnu: Add go-go-etcd-io-bbolt.
* gnu/packages/databases.scm (go-go-etcd-io-bbolt): New variable.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index aa1711c911..cfa1743d75 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2715,6 +2715,34 @@ on another machine, accessed via TCP/IP.")
     (home-page "http://pqxx.org/")
     (license license:bsd-3)))
 
+(define-public go-go-etcd-io-bbolt
+  (package
+    (name "go-go-etcd-io-bbolt")
+    (version "1.3.6")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/etcd-io/bbolt")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "go.etcd.io/bbolt"
+       ;; Extending the test timeout to 30 minutes still times out on aarch64.
+       #:tests? ,(not target-arm?)))
+    (propagated-inputs
+     (list go-golang-org-x-sys))
+    (home-page "https://go.etcd.io/bbolt")
+    (synopsis "Embedded key/value database for Go")
+    (description "Bolt is a pure Go key/value store inspired by Howard Chu's
+LMDB project.  The goal of the project is to provide a simple, fast, and
+reliable database for projects that don't require a full database server such as
+Postgres or MySQL.")
+    (license license:expat)))
+
 (define-public python-peewee
   (package
     (name "python-peewee")