summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-09-06 20:30:45 +0800
committerMarius Bakke <marius@gnu.org>2022-09-07 22:02:40 +0200
commit53c127c16defa1c0456dfc86df4cba5b267b0991 (patch)
treecc1f4cf353eed24ba45295c8941c7288693b1a8c /gnu/packages/databases.scm
parentb7629ff995c49a3025b6edf3b240b48fe4b5b942 (diff)
downloadguix-53c127c16defa1c0456dfc86df4cba5b267b0991.tar.gz
gnu: python-apsw: Update to 3.39.2.1.
* gnu/packages/databases.scm (python-apsw): Update to 3.39.2.1.
[source]: Change back to compressed release.
* gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch: New file.
* gnu/local.mk: Add patch.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7edf0fed2d..9540b61920 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3568,18 +3568,22 @@ PickleShare.")
 (define-public python-apsw
   (package
     (name "python-apsw")
-    (version "3.39.2.0")
+    (version "3.39.2.1")
+    ;; The compressed release has fetching functionality disabled.
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/rogerbinns/apsw")
-             (commit version)))
-       (file-name (git-file-name name version))
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/rogerbinns/apsw/releases/download/"
+             version "/apsw-" version ".zip"))
        (sha256
         (base32
-         "0q7fnk8n3m5mpjzh6xyhj409k8sacdbjsfis98my9c50fdn5sr7y"))))
+         "06x3qgg71xz8l3kz8gz04wkfp5f6zfrg476a4mm1c5hikqyw6ykj"))
+       ;; Cherry-picked from upstream, remove when bumping to 3.39.3.
+       (patches
+        (search-patches "python-apsw-3.39.2.1-test-fix.patch"))))
     (build-system python-build-system)
+    (native-inputs (list unzip))
     (inputs (list sqlite-next))         ;SQLite 3.39 required.
     (arguments
      (list #:phases