summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-29 11:00:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-29 11:00:32 +0300
commit8d02c2c39e647206482debf3ae943ae6198b1fd0 (patch)
treef832a30c6a924f822348f2aef1853a88a20ddec1 /gnu/packages/databases.scm
parentb1ef2deb66f4794c96557801eca3808a61f1f218 (diff)
downloadguix-8d02c2c39e647206482debf3ae943ae6198b1fd0.tar.gz
gnu: mariadb: Update to 10.5.12.
* gnu/packages/databases.scm (mariadb): Update to 10.5.12.
[source]: Remove patches.
[arguments]: In custom 'adjust-tests phase, update list of skipped
tests. Also remove tests already listed in mysql-test/unstable-tests.
* gnu/packages/patches/mariadb-CVE-2021-27928.patch,
gnu/packages/patches/mariadb-cmake-compat.patch: Remove files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 93336aeb5f..a15c0669a4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -719,7 +719,7 @@ Language.")
 (define-public mariadb
   (package
     (name "mariadb")
-    (version "10.5.8")
+    (version "10.5.12")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://downloads.mariadb.com/MariaDB"
@@ -727,9 +727,7 @@ Language.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1s3vfm73911cddjhgpcbkya6nz7ag2zygg56qqzwscn5ybv28j7b"))
-              (patches (search-patches "mariadb-CVE-2021-27928.patch"
-                                       "mariadb-cmake-compat.patch"))
+                "1gg4h9ahmk78cx01zyw0fqr6hhd78fsyhs0s34p3gi9hkak1qkxb"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -839,29 +837,25 @@ Language.")
                     '(;; These fail because root@hostname == root@localhost in
                       ;; the build environment, causing a user count mismatch.
                       ;; See <https://jira.mariadb.org/browse/MDEV-7761>.
-                      "funcs_1.is_columns_mysql"
-                      "main.join_cache"
                       "main.explain_non_select"
-                      "main.stat_tables"
-                      "main.stat_tables_innodb"
                       "main.upgrade_MDEV-19650"
                       "roles.acl_statistics"
 
+                      ;; Probably same as above, test failure reported upstream:
+                      ;; <https://jira.mariadb.org/browse/MDEV-26320>.
+                      "main.selectivity_no_engine"
+
                       ;; FIXME: This test checks various table encodings and
                       ;; fails because Guix defaults to UTF8 instead of the
                       ;; upstream default latin1_swedish_ci.  It's not easily
                       ;; substitutable because several encodings are tested.
-                      "main.sp2"
+                      "main.system_mysql_db"
 
                       ;; XXX: This test occasionally fails on i686-linux:
                       ;; <https://jira.mariadb.org/browse/MDEV-24458>
                       ,@(if (string-prefix? "i686" (%current-system))
                             '("main.myisampack")
-                            '())
-
-                      ;; This file contains a time bomb which makes it fail after
-                      ;; 2030-12-31.  See <https://bugs.gnu.org/34351> for details.
-                      "main.mysqldump"))
+                            '())))
 
                    ;; This file contains a list of known-flaky tests for this
                    ;; release.  Append our own items.