summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 21:18:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:53 -0400
commit9f917c945eb4fd2478823d3c73f4a2db30be1b07 (patch)
tree99c8f3d3e754822cf56bbeb47b043ac7fc1173f2 /gnu/packages/databases.scm
parentf7363b2479560961f66f2e1eaf055d681c19fce3 (diff)
downloadguix-9f917c945eb4fd2478823d3c73f4a2db30be1b07.tar.gz
gnu: Remove python2-sqlalchemy.
* gnu/packages/databases.scm (python2-sqlalchemy): Delete variable.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index f90a1b6c74..7be109a6bc 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3364,30 +3364,6 @@ designed for efficient and high-performing database access, adapted into a
 simple and Pythonic domain language.")
     (license license:x11)))
 
-(define-public python2-sqlalchemy
-  (let ((base (package-with-python2 python-sqlalchemy)))
-    (package
-      (inherit base)
-      (arguments
-       (substitute-keyword-arguments (package-arguments base)
-         ((#:phases phases)
-          #~(modify-phases #$phases
-              (replace 'check
-                (lambda* (#:key tests? #:allow-other-keys)
-                  (when tests?
-                    (invoke "pytest" "-vv"
-                            ;; The memory usage tests are very expensive and run in
-                            ;; sequence; skip them.
-                            "-k"
-                            (string-append
-                             "not test_memusage.py"
-                             ;; This test fails with "AssertionError: Warnings
-                             ;; were not seen [...]".
-                             " and not test_fixture_five")))))))))
-      ;; Do not use pytest-xdist, which is broken for Python 2.
-      (native-inputs (modify-inputs (package-native-inputs base)
-                       (delete "python-pytest-xdist"))))))
-
 (define-public python-sqlalchemy-stubs
   (package
     (name "python-sqlalchemy-stubs")