summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-26 08:37:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-26 08:37:17 +0300
commitffcc5395b790035e22cbb155b4e30bd4152915e1 (patch)
treeac25f6c34e0d6837a2e460e1225617c6de27ce58 /gnu/packages/databases.scm
parentcab17c1c3744994f093d31b3a282cce7c6c5ed4f (diff)
downloadguix-ffcc5395b790035e22cbb155b4e30bd4152915e1.tar.gz
gnu: mariadb: Only enable parallel tests on x86_64-linux.
* gnu/packages/databases.scm (mariadb)[arguments]: Only enable parallel
tests when building on x86_64-linux.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8701cc3bfe..1849eca702 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -831,10 +831,10 @@ Language.")
                         "/share/mysql/support-files")
          "-DINSTALL_MYSQLSHAREDIR=share/mysql"
          "-DINSTALL_SHAREDIR=share")
-       ;; The testsuite has spurious failures (mostly timeouts) if run in
-       ;; parallel on Guix CI’s ppc64le VM. It appears that the I/O load is
-       ;; too high for it to handle.
-       #:parallel-tests? ,(not (target-ppc64le?))
+       ;; The test suite has spurious failures (mostly timeouts) if run in
+       ;; parallel on various machines.  Only enable parallel tests on
+       ;; architectures which are likely to not have this issue.
+       #:parallel-tests? ,(target-x86-64?)
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'adjust-output-references