summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-11-22 10:36:59 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-11-30 18:21:23 +0530
commit6e385b76e666bdf26fe4eebaffa93e48c123e5ef (patch)
tree403b68aed4d8ff0e157f9528130a76e8af9b6c82 /gnu/packages/databases.scm
parentbc27eb3b56bbe251b32b810d3d899951e61b476a (diff)
downloadguix-6e385b76e666bdf26fe4eebaffa93e48c123e5ef.tar.gz
gnu: mongodb: Use scons-build-system.
* gnu/packages/databases.scm (mongodb): Switch to scons-build-system.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ab4d17479c..56749320b3 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -98,6 +98,7 @@
   #:use-module (guix build-system ruby)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system r)
+  #:use-module (guix build-system scons)
   #:use-module ((guix build utils) #:hide (which))
   #:use-module (guix utils)
   #:use-module (srfi srfi-1)
@@ -398,7 +399,7 @@ applications.")
               (patches
                (list
                 (search-patch "mongodb-support-unknown-linux-distributions.patch")))))
-    (build-system gnu-build-system)
+    (build-system scons-build-system)
     (inputs
      `(("openssl" ,openssl)
        ("pcre" ,pcre)
@@ -410,12 +411,11 @@ applications.")
        ("zlib" ,zlib)
        ("snappy" ,snappy)))
     (native-inputs
-     `(("scons" ,scons)
-       ("python" ,python-2)
-       ("valgrind" ,valgrind)
+     `(("valgrind" ,valgrind)
        ("perl" ,perl)))
     (arguments
-     `(#:phases
+     `(#:scons ,scons-python2
+       #:phases
        (let ((common-options
               `(;; "--use-system-tcmalloc" TODO: Missing gperftools
                 "--use-system-pcre"
@@ -437,7 +437,6 @@ applications.")
                 ,(format #f "--jobs=~a" (parallel-job-count))
                 "--ssl")))
          (modify-phases %standard-phases
-           (delete 'configure) ; There is no configure phase
            (add-after 'unpack 'scons-propagate-environment
              (lambda _
                ;; Modify the SConstruct file to arrange for