summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-11-05 02:55:49 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-11-08 22:05:22 +0200
commit831f1ff92ea561929db36bc54070fd2ba11b4a7e (patch)
treeeb3890cd125c7ccfbf40de3bad1e056b59ad5c03 /gnu/packages/databases.scm
parent1b5c7052c977861789060409877325551535a681 (diff)
downloadguix-831f1ff92ea561929db36bc54070fd2ba11b4a7e.tar.gz
gnu: python-peewee: Update to 3.13.3.
* gnu/packages/databases.scm (python-peewee): Update to 3.13.3.
[inputs]: Add sqlite.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index f7de8d1464..b164f8e6d9 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2436,17 +2436,19 @@ on another machine, accessed via TCP/IP.")
 (define-public python-peewee
   (package
     (name "python-peewee")
-    (version "3.9.6")
-      (source
-        (origin
-        (method url-fetch)
-        (uri (pypi-uri "peewee" version))
-        (sha256
-         (base32
-          "1j4sh946k0736m7pd54z0y6i2hjhgg3kdllx1pwq8xkzzcgrx1xw"))))
+    (version "3.13.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "peewee" version))
+       (sha256
+        (base32
+         "0sc376v6rxga4b7ic9kxw2pmf28rmcx016320pa2nlb5d1rsjs8j"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f)) ; Fails to import test data
+    (inputs
+     `(("sqlite" ,sqlite)))
     (native-inputs
      `(("python-cython" ,python-cython)))
     (home-page "https://github.com/coleifer/peewee/")