summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-09-11 22:32:32 +0200
committerAndreas Enge <andreas@enge.fr>2015-09-11 22:36:50 +0200
commite4c3e2cd439f6a330fbd459097a1b79be41b4e56 (patch)
tree36055953a174dbb7c5fd69f36999096c798c06e5 /gnu/packages/databases.scm
parent41996f22abd9a0f03893177f1fcf1a76731025bb (diff)
downloadguix-e4c3e2cd439f6a330fbd459097a1b79be41b4e56.tar.gz
gnu: bdb: Add configure flag to fix C++ header file.
* gnu/packages/databases.scm (bdb): Build with "--enable-cxx", which causes
  HAVE_CXX_STDHEADERS to be defined in db_cxx.h in the output.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index e978c54ee5..38ff650465 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2012, 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2012, 2014, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
 ;;; Copyright © 2014 David Thompson <davet@gnu.org>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
@@ -87,7 +87,12 @@
 
                       ;; The compatibility mode is needed by some packages,
                       ;; notably iproute2.
-                      "--enable-compat185"))))
+                      "--enable-compat185"
+
+                      ;; The following flag is needed so that the inclusion
+                      ;; of db_cxx.h into C++ files works; it leads to
+                      ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
+                      "--enable-cxx"))))
                  %standard-phases)))
     (synopsis "Berkeley database")
     (description