summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-15 15:03:33 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-15 15:09:08 +0100
commit45ebd90c186558556f2fe28ff2eb0cd424768b55 (patch)
treeafab91b76f2a0bdddc203080247e2e8e4c05e8c5 /gnu/packages/databases.scm
parentbaea210c04fd9e36340379b580331c9aeea6378b (diff)
downloadguix-45ebd90c186558556f2fe28ff2eb0cd424768b55.tar.gz
gnu: python-alembic: Update to 1.4.1.
* gnu/packages/patches/python-alembic-exceptions-cause.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/databases.scm (python-alembic): Update to 1.4.1.
[source](patches): New field.
[arguments]: New field, override check phase.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index a4854580e8..be4db42332 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2613,15 +2613,21 @@ You might also want to install the following optional dependencies:
 (define-public python-alembic
   (package
     (name "python-alembic")
-    (version "1.0.11")
+    (version "1.4.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "alembic" version))
+       (patches (search-patches "python-alembic-exceptions-cause.patch"))
        (sha256
         (base32
-         "1k5hag0vahd5vrf9abx8fdj2whrwaw2iq2yp736mmxnbsn5xkdyd"))))
+         "0a4hzn76csgbf1px4f5vfm256byvjrqkgi9869nkcjrwjn35c6kr"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "pytest" "-vv"))))))
     (native-inputs
      `(("python-mock" ,python-mock)
        ("python-pytest-cov" ,python-pytest-cov)))