summary refs log tree commit diff
path: root/gnu/packages/datastructures.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-29 14:36:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-29 15:47:13 +0200
commit9b26efdd2a541036adeb686a54f4093549b8f070 (patch)
treef971fe80f6f2be1a3f341fb544ad6efeb76ff78c /gnu/packages/datastructures.scm
parent809a3f72d1c07c322ccf6a51af28647add9ea442 (diff)
downloadguix-9b26efdd2a541036adeb686a54f4093549b8f070.tar.gz
gnu: marisa: Update to 0.2.6.
* gnu/packages/datastructures.scm (marisa): Update to 0.2.6.
[source]: Use worse URL.
[native-inputs]: Add autoconf, automake, and libtool.
Diffstat (limited to 'gnu/packages/datastructures.scm')
-rw-r--r--gnu/packages/datastructures.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 0f106b7ce9..b649f9e848 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -21,6 +21,7 @@
 
 (define-module (gnu packages datastructures)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages perl)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
@@ -55,16 +56,19 @@ and heaps.")
 (define-public marisa
   (package
     (name "marisa")
-    (version "0.2.5")
+    (version "0.2.6")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://github.com/s-yata/marisa-trie"
-                           "/releases/download/v" version "/" name "-"
-                           version ".tar.gz"))
+       (uri (string-append "https://github.com/s-yata/marisa-trie/files/"
+                           "4832504/marisa-" version ".tar.gz"))
        (sha256
-        (base32 "19ifrcmnbr9whaaf4ly3s9ndyiq9sjqhnfkrxbz9zsb44w2n36hf"))))
+        (base32 "1pk6wmi28pa8srb4szybrwfn71jldb61c5vgxsiayxcyg1ya4qqh"))))
     (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
     (home-page "https://github.com/s-yata/marisa-trie")
     (synopsis "Trie data structure C++ library")
     (description "Matching Algorithm with Recursively Implemented