summary refs log tree commit diff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-13 16:17:29 -0400
committerLeo Famulari <leo@famulari.name>2016-03-13 18:26:48 -0400
commit36455a9672af56f76c495ba7f65c774111d7e5e9 (patch)
treea13dcb699e45396b824d39739e04d25b64232482 /gnu/packages/dav.scm
parentbea6d94d2498f45b5dc99375ab367ffa51a6abfd (diff)
downloadguix-36455a9672af56f76c495ba7f65c774111d7e5e9.tar.gz
gnu: vdirsyncer: Update 0.9.2.
* gnu/packages/dav.scm (vdirsyncer): Update to 0.9.2.
[arguments]: Run the test suite after installation. Use DETERMINISTIC_TESTS.
Run tests with `make` instead of "py.test".
[native-inputs]: Remove python-pytest-xprocess and python-oauthlib.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm26
1 files changed, 14 insertions, 12 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 4562193114..de984faf33 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -52,21 +52,16 @@ clients.")
 (define-public vdirsyncer
   (package
     (name "vdirsyncer")
-    (version "0.9.0")
+    (version "0.9.2")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri "vdirsyncer" version))
              (sha256
               (base32
-               "0s9awjr9v60rr80xcpwmdhkf4v1yqnydahjmxwvxmh64565is465"))))
+               "1g1107cz4sk41d2z6k6pn9n2fzd26m72j8aj33zn483vfvmyrc4q"))))
     (build-system python-build-system)
     (arguments
       `(#:phases (modify-phases %standard-phases
-         (replace 'check
-           (lambda _
-             (setenv "DAV_SERVER" "radicale")
-             (setenv "REMOTESTORAGE_SERVER" "skip")
-             (zero? (system* "py.test"))))
          ;; vdirsyncer requires itself to be installed in order to build
          ;; the manpage.
          (add-after 'install 'manpage
@@ -80,17 +75,24 @@ clients.")
                "docs/_build/man/vdirsyncer.1"
                (string-append
                  (assoc-ref outputs "out")
-                 "/share/man/man1")))))))
+                 "/share/man/man1"))))
+         ;; vdirsyncer requires itself to be installed in order to run the test
+         ;; suite.
+         (delete 'check)
+         (add-after 'install 'check-later
+           (lambda _
+             (setenv "DETERMINISTIC_TESTS" "true")
+             (setenv "DAV_SERVER" "radicale")
+             (setenv "REMOTESTORAGE_SERVER" "skip")
+             (zero? (system* "make" "test")))))))
     (native-inputs
-     `(("python-oauthlib" ,python-oauthlib)
-       ("python-setuptools-scm" ,python-setuptools-scm)
+     `(("python-setuptools-scm" ,python-setuptools-scm)
        ("python-sphinx" ,python-sphinx)
        ;; Required for testing
        ("python-hypothesis" ,python-hypothesis)
        ("python-pytest" ,python-pytest)
        ("python-pytest-localserver" ,python-pytest-localserver)
        ("python-pytest-subtesthack" ,python-pytest-subtesthack)
-       ("python-pytest-xprocess" ,python-pytest-xprocess)
        ("python-wsgi-intercept" ,python-wsgi-intercept)
        ("radicale" ,radicale)))
     (propagated-inputs
@@ -98,7 +100,7 @@ clients.")
        ("python-click" ,python-click)
        ("python-click-log" ,python-click-log)
        ("python-click-threading" ,python-click-threading)
-       ("python-lxml" ,python-lxml) ; which one?
+       ("python-lxml" ,python-lxml)
        ("python-requests-toolbelt" ,python-requests-toolbelt)))
     (synopsis "Synchronize calendars and contacts")
     (description "Vdirsyncer synchronizes your calendars and addressbooks