summary refs log tree commit diff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-01 09:30:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-01 09:30:56 +0300
commit8ed5d9502dffe6884978fab32398f9c68e38a6c8 (patch)
treefbf04e924fd7166090e2e8a807f88d2739acc103 /gnu/packages/dav.scm
parent21131e9c6d1ff623393bed2e5b41e3c22719edc7 (diff)
downloadguix-8ed5d9502dffe6884978fab32398f9c68e38a6c8.tar.gz
gnu: vdirsyncer: Don't propagate python-click-5.
This prevents a profile collision when installing the package.

* gnu/packages/dav.scm (vdirsyncer)[propagated-inputs]: Move
python-click-5 ...
[inputs]: ... to here.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index dbfa4a660e..b9e210c84b 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -107,10 +107,11 @@ clients.")
        ("python-urllib3" ,python-urllib3)
        ("python-wsgi-intercept" ,python-wsgi-intercept)
        ("radicale" ,radicale)))
+    (inputs
+     `(;; XXX https://github.com/mitsuhiko/click/issues/200
+       ("python-click" ,python-click-5)))
     (propagated-inputs
      `(("python-atomicwrites" ,python-atomicwrites)
-       ;; XXX https://github.com/mitsuhiko/click/issues/200
-       ("python-click" ,python-click-5)
        ("python-click-log" ,python-click-log)
        ("python-click-threading" ,python-click-threading)
        ("python-requests-toolbelt" ,python-requests-toolbelt)))