summary refs log tree commit diff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-04-26 03:05:41 -0400
committerLeo Famulari <leo@famulari.name>2016-04-27 14:04:08 -0400
commit38e2104c5d9b860c0e41c036895dcf178eca2ce0 (patch)
tree0bf71f6d823e58c7608923e6a7c93a5bd6bc2878 /gnu/packages/dav.scm
parent5d88b4f8a8d92d8b66755f6e15dad3a88732adf9 (diff)
downloadguix-38e2104c5d9b860c0e41c036895dcf178eca2ce0.tar.gz
gnu: vdirsyncer: Update to 0.10.0.
* gnu/packages/dav.scm (vdirsyncer): Update to 0.10.0.
[propagated-inputs]: Remove python-lxml.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 6815a6b250..2bbc069472 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -52,13 +52,16 @@ clients.")
 (define-public vdirsyncer
   (package
     (name "vdirsyncer")
-    (version "0.9.3")
+    (version "0.10.0")
     (source (origin
              (method url-fetch)
-             (uri (pypi-uri "vdirsyncer" version))
+             (uri (string-append "https://pypi.python.org/packages/0b/fb/"
+                                 "c42223e1e9169e4770194e62143d431755724b080d8cb"
+                                 "77f14705b634815/"
+                                 "vdirsyncer-" version ".tar.gz"))
              (sha256
               (base32
-               "1wjhzjfcvwz68j6wc5cmjsw69ggwcpfy7jp7z7q6fnwwp4dr98lc"))))
+               "1gf86sbd6w0w4zayh9r3irlp5jwrzbjikjc0vs5zkdpa5c199f78"))))
     (build-system python-build-system)
     (arguments
       `(#:phases (modify-phases %standard-phases
@@ -100,7 +103,6 @@ clients.")
        ("python-click" ,python-click)
        ("python-click-log" ,python-click-log)
        ("python-click-threading" ,python-click-threading)
-       ("python-lxml" ,python-lxml)
        ("python-requests-toolbelt" ,python-requests-toolbelt)))
     (synopsis "Synchronize calendars and contacts")
     (description "Vdirsyncer synchronizes your calendars and addressbooks