summary refs log tree commit diff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/dav.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running:

  ./pre-inst-env guix style

without any additional argument.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm60
1 files changed, 28 insertions, 32 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 712149f173..8738eb36f2 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -53,17 +53,15 @@
         (base32 "1xlsvrmx6jhi71j6j8z9sli5vwxasivzjyqf8zq8r0l5p7350clf"))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-pytest" ,python-pytest)
-       ("python-pytest-cov" ,python-pytest-cov)
-       ("python-pytest-flake8" ,python-pytest-flake8)
-       ("python-pytest-isort" ,python-pytest-isort)
-       ("python-pytest-runner" ,python-pytest-runner)
-       ("python-waitress" ,python-waitress)))
+     (list python-pytest
+           python-pytest-cov
+           python-pytest-flake8
+           python-pytest-isort
+           python-pytest-runner
+           python-waitress))
     (propagated-inputs
-     `(("python-dateutil" ,python-dateutil)
-       ("python-defusedxml" ,python-defusedxml)
-       ("python-passlib" ,python-passlib)
-       ("python-vobject" ,python-vobject)))
+     (list python-dateutil python-defusedxml python-passlib
+           python-vobject))
     (synopsis "Basic CalDAV and CardDAV server")
     (description "Radicale is a CalDAV and CardDAV server for UNIX-like
 platforms.  Calendars and address books are available for both local and remote
@@ -88,12 +86,12 @@ clients.")
         (base32 "13ikmcja9p42azb5ccqj2bw98zybna6zlflj10hqy0kvbib70l94"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-aiohttp" ,python-aiohttp)
-       ("python-defusedxml" ,python-defusedxml)
-       ("python-dulwich" ,python-dulwich)
-       ("python-icalendar" ,python-icalendar)
-       ("python-jinja2" ,python-jinja2)
-       ("python-multidict" ,python-multidict)))
+     (list python-aiohttp
+           python-defusedxml
+           python-dulwich
+           python-icalendar
+           python-jinja2
+           python-multidict))
     (home-page "https://www.xandikos.org/")
     (synopsis "Lightweight CalDAV/CardDAV server")
     (description
@@ -153,24 +151,22 @@ efficient syncing
                 "/share/man/man1"))
             #t)))))
     (native-inputs
-     `(("python-setuptools-scm" ,python-setuptools-scm)
-       ("python-sphinx" ,python-sphinx)
-       ;; Required for testing
-       ("python-hypothesis" ,python-hypothesis)
-       ("python-pytest" ,python-pytest)
-       ("python-pytest-localserver" ,python-pytest-localserver)
-       ("python-pytest-subtesthack" ,python-pytest-subtesthack)
-       ("python-urllib3" ,python-urllib3)
-       ("python-wsgi-intercept" ,python-wsgi-intercept)
-       ("radicale" ,radicale)))
+     (list python-setuptools-scm
+           python-sphinx
+           ;; Required for testing
+           python-hypothesis
+           python-pytest
+           python-pytest-localserver
+           python-pytest-subtesthack
+           python-urllib3
+           python-wsgi-intercept
+           radicale))
     (inputs
-     `(;; XXX https://github.com/mitsuhiko/click/issues/200
-       ("python-click" ,python-click-5)))
+     (list ;; XXX https://github.com/mitsuhiko/click/issues/200
+           python-click-5))
     (propagated-inputs
-     `(("python-atomicwrites" ,python-atomicwrites)
-       ("python-click-log" ,python-click-log)
-       ("python-click-threading" ,python-click-threading)
-       ("python-requests-toolbelt" ,python-requests-toolbelt)))
+     (list python-atomicwrites python-click-log python-click-threading
+           python-requests-toolbelt))
     (synopsis "Synchronize calendars and contacts")
     (description "Vdirsyncer synchronizes your calendars and addressbooks
 between two storage locations.  The most popular purpose is to