summary refs log tree commit diff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-21 00:34:32 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-21 00:36:23 +0100
commit06da1a6b4fa919a64020ebf1a001b7e66134bd97 (patch)
treed4ecec28ab52712b5a1753732180350a4d70b282 /gnu/packages/debug.scm
parentbb38ece4585679c27ecc1f5a063f75dfbf864a45 (diff)
downloadguix-06da1a6b4fa919a64020ebf1a001b7e66134bd97.tar.gz
gnu: Add qemu-minimal.
* gnu/packages/qemu.scm (qemu): Exchange with former QEMU-HEADLESS.
(qemu-headless): Rename to...
(qemu-minimal): ... this.  New variable.  Pass --target-list.
* gnu/packages/debug.scm (qemu-2.3.0): Inherit from QEMU-MINIMAL.
* gnu/packages/grub.scm (qemu-for-tests): Likewise.
* gnu/system/vm.scm (expression->derivation-in-linux-vm, qemu-image):
Update to name change.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 1e0034c100..dc94f97657 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -143,7 +143,7 @@ tools that process C/C++ code.")
 
 (define qemu-2.3.0
   (package
-    (inherit qemu-headless)
+    (inherit qemu-minimal)
     (version "2.3.0")
     (source (origin
               (method url-fetch)
@@ -157,7 +157,7 @@ tools that process C/C++ code.")
      ;; XXX: Disable tests because of GTester's rejection of duplicate test
      ;; names, which wasn't addressed in this version of QEMU.
      `(#:tests? #f
-       ,@(package-arguments qemu-headless)))))
+       ,@(package-arguments qemu-minimal)))))
 
 (define-public american-fuzzy-lop
   (let ((machine (match (or (%current-target-system)