summary refs log tree commit diff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-13 16:19:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-15 22:19:39 +0100
commitf38607536e10f8991bf67d4f6dc5e0632f206f47 (patch)
treeafc0f26bdbd9b67a7ca5bcdef7872e4f9a0dac2a /gnu/packages/debug.scm
parent618e4bfbad0740c4addc9e88d9667d5dc65b0bce (diff)
downloadguix-f38607536e10f8991bf67d4f6dc5e0632f206f47.tar.gz
gnu: Use INSTALL-FILE where appropriate.
* gnu/packages/admin.scm (wpa-supplicant-minimal): Substitute the simpler
INSTALL-FILE for COPY-FILE when invoked with redundant arguments.
* gnu/packages/bioinformatics.scm (couger, aragorn, express-beta-diversity,
edirect, fasttree, rsem, samtools-0.1): Likewise.
* gnu/packages/code.scm (withershins): Likewise.
* gnu/packages/conky.scm (conky): Likewise.
* gnu/packages/debug.scm (delta, american-fuzzy-lop): Likewise.
* gnu/packages/emacs.scm (emacs-mit-scheme-doc): Likewise.
* gnu/packages/engineering.scm (librecad): Likewise.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 6278f661ef..27193c8bba 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -68,10 +68,10 @@
               (mkdir-p bin)
               (mkdir-p doc)
               (for-each (lambda (h)
-                          (copy-file h (string-append doc "/" (basename h))))
+                          (install-file h doc))
                         `("License.txt" ,@(find-files "www" ".*\\.html")))
               (for-each (lambda (b)
-                          (copy-file b (string-append bin "/" b)))
+                          (install-file b bin))
                         `("delta" "multidelta" "topformflat")))))
         (alist-delete 'configure %standard-phases))))
     (home-page "http://delta.tigris.org/")
@@ -212,13 +212,13 @@ tools that process C/C++ code.")
                                       (system* "tar" "xf"
                                                (assoc-ref inputs "afl-src")))
                                (error "tar failed to unpack afl-src"))
-                             (copy-file (string-append patch-dir
-                                                       "/afl-qemu-cpu-inl.h")
-                                        "./afl-qemu-cpu-inl.h")
+                             (install-file (string-append patch-dir
+                                                          "/afl-qemu-cpu-inl.h")
+                                           ".")
                              (copy-file (string-append afl-dir "/config.h")
                                         "./afl-config.h")
-                             (copy-file (string-append afl-dir "/types.h")
-                                        "./types.h")
+                             (install-file (string-append afl-dir "/types.h")
+                                           ".")
                              (substitute* "afl-qemu-cpu-inl.h"
                                (("\\.\\./\\.\\./config.h") "afl-config.h"))
                              (substitute* (string-append patch-dir