summary refs log tree commit diff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-04-04 12:08:08 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-04 12:45:36 +0200
commita5a2d79b91b07c231622a92f9322ea7ebf5d9c77 (patch)
tree8d664098dcc9ef3365dde99acaa00db6840a8601 /gnu/packages/debug.scm
parentd6f1f60721f36a333f8bd0696c81126c92dcd1b8 (diff)
downloadguix-a5a2d79b91b07c231622a92f9322ea7ebf5d9c77.tar.gz
gnu: c-reduce: Make some inputs native.
* gnu/packages/debug.scm (c-reduce)[inputs]: Move flex from here...
[native-inputs]: ...to this new field.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 75dd94d868..4a264427c2 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -119,11 +120,11 @@ program to exhibit a bug.")
       (sha256
        (base32 "0qx0zq8jxzx2as2zf0740g7kvgq163ayn3041di4vwk77490y76v"))))
     (build-system gnu-build-system)
+    (native-inputs `(("flex" ,flex)))
     (inputs
      `(("astyle"          ,astyle)
        ("llvm"            ,llvm)
        ("clang"           ,clang)
-       ("flex"            ,flex)
        ("indent"          ,indent)
        ("perl"            ,perl)
        ("exporter-lite"   ,perl-exporter-lite)