summary refs log tree commit diff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 02:43:54 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 15:52:56 +0100
commit139ecdee8e592c515eea8cff4b918f0655196b4c (patch)
tree6a48a1d28354cc689b85987f27e9e3a246bdd4b0 /gnu/packages/debug.scm
parentdefe0282c29cbc9bdb774ebdf8095a02c4aaea98 (diff)
downloadguix-139ecdee8e592c515eea8cff4b918f0655196b4c.tar.gz
gnu: delta: Remove redundant code.
* gnu/packages/debug.scm (delta)[arguments]: Remove unneeded MKDIR-P
calls.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 2354f0fbb9..6b566b0097 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -66,8 +66,6 @@
                     (bin (string-append out "/bin"))
                     (doc (string-append out "/share/doc/delta-" ,version)))
                (begin
-                 (mkdir-p bin)
-                 (mkdir-p doc)
                  (for-each (lambda (h)
                              (install-file h doc))
                            `("License.txt" ,@(find-files "www" ".*\\.html")))
@@ -75,7 +73,7 @@
                              (install-file b bin))
                            `("delta" "multidelta" "topformflat"))))
              #t))
-         (delete 'configure))))
+         (delete 'configure))))         ; no configure script
     (home-page "http://delta.tigris.org/")
     (synopsis "Heuristical file minimizer")
     (description