summary refs log tree commit diff
path: root/gnu/packages/dhall.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-09 18:10:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-09 23:52:19 +0200
commit5e7daec9b4bfd2a3a430fc800ab6b1b527a5fa27 (patch)
tree86ed90a722ca41785d4f3fc5a877f4c050007a54 /gnu/packages/dhall.scm
parent3a629d36e92edd3452b69d556b6e8ac91618b157 (diff)
downloadguix-5e7daec9b4bfd2a3a430fc800ab6b1b527a5fa27.tar.gz
gnu: dhall: Disable network tests differently.
* gnu/packages/dhall.scm (dhall)[source]: Remove patch.
[arguments]: Rename ‘remove-more-tests’ phase to ‘remove-network-tests’.
Identify the tests by name instead of by content.
* gnu/packages/patches/dhall-remove-network-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/dhall.scm')
-rw-r--r--gnu/packages/dhall.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/dhall.scm b/gnu/packages/dhall.scm
index bbe2d271d7..86cbe764c6 100644
--- a/gnu/packages/dhall.scm
+++ b/gnu/packages/dhall.scm
@@ -1,4 +1,5 @@
 ;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -39,8 +40,7 @@
              ".tar.gz"))
        (sha256
         (base32
-         "18v7vvcbcm9s7slh6h43rj9yakkkxwnwgj6kv84i6qzd2j7d80mc"))
-       (patches (search-patches "dhall-remove-network-tests.patch"))))
+         "18v7vvcbcm9s7slh6h43rj9yakkkxwnwgj6kv84i6qzd2j7d80mc"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-aeson" ,ghc-aeson)
@@ -99,9 +99,23 @@
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         ;; Remove tests that require network
-         (add-after 'unpack 'remove-more-tests
+         (add-after 'unpack 'remove-network-tests
            (lambda _
+             (with-directory-excursion "dhall-lang/tests"
+               (for-each
+                delete-file
+                '("import/failure/referentiallyInsane.dhall"
+                  "import/success/customHeadersA.dhall"
+                  "import/success/noHeaderForwardingA.dhall"
+                  "import/success/unit/RemoteAsTextA.dhall"
+                  "import/success/unit/SimpleRemoteA.dhall"
+                  "import/success/unit/asLocation/RemoteChain1A.dhall"
+                  "import/success/unit/asLocation/RemoteChain2A.dhall"
+                  "import/success/unit/asLocation/RemoteChain3A.dhall"
+                  "import/success/unit/asLocation/RemoteChainEnvA.dhall"
+                  "import/success/unit/asLocation/RemoteChainMissingA.dhall"
+                  "type-inference/success/CacheImportsA.dhall"
+                  "type-inference/success/CacheImportsCanonicalizeA.dhall")))
              (substitute* "src/Dhall/Tutorial.hs"
                (((string-append
                   "-- >>> input auto "