summary refs log tree commit diff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-09-05 11:13:22 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-09-19 11:39:52 -0700
commit4d83157cd806aeb864664ebb380c19f6be04648c (patch)
tree2f0c4622c7ae9fa1f9b6cbba9b8cd38a67408a62 /gnu/packages/diffoscope.scm
parentf315673d9e56f4f2398098590ebdc080b63ce8b1 (diff)
downloadguix-4d83157cd806aeb864664ebb380c19f6be04648c.tar.gz
gnu: Add wabt.
* gnu/packages/web (wabt): New variable.
* gnu/packages/diffoscope (diffoscope)[native-inputs]: Add wabt for tests.
  [arguments]: Add phase patching wabt into known tools.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 17a2d212e5..e2b2565004 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -57,6 +57,7 @@
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages video)
   #:use-module (gnu packages vim)
+  #:use-module (gnu packages web)
   #:use-module (guix build-system python)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
@@ -88,6 +89,12 @@
                       (lambda _
                         (substitute* "setup.py"
                           (("'python-magic',") ""))))
+                    ;; Patch in support for known tools
+                    (add-after 'unpack 'add-known-tools
+                      (lambda _
+                        (substitute* "diffoscope/external_tools.py"
+                          (("'arch': 'wabt'},")
+                           "'arch': 'wabt', 'guix': 'wabt'},"))))
                     ;; This test is broken because our `file` package has a
                     ;; bug in berkeley-db file type detection.
                     (add-after 'unpack 'remove-berkeley-test
@@ -188,6 +195,7 @@
                        ("squashfs-tools" ,squashfs-tools)
                        ("tcpdump" ,tcpdump)
                        ("unzip" ,unzip)
+                       ("wabt" ,wabt)
                        ("xxd" ,xxd)
                        ("xz" ,xz)
                        ("zip" ,zip)))