summary refs log tree commit diff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-24 15:07:35 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-24 15:09:30 +0000
commitb142611b361fc41da7353d0e5b0854bf6ea32501 (patch)
treed6f95e7204f3f4a77c0bb055c553dc36c63ff842 /gnu/packages/diffoscope.scm
parent1d9cf387b36215de206f331d9a906d30cb37c2a8 (diff)
downloadguix-b142611b361fc41da7353d0e5b0854bf6ea32501.tar.gz
gnu: diffoscope: Disable another broken libfile test.
* gnu/packages/diffoscope.scm (diffoscope)[arguments]: Rename build phase
'remove-berkeley-test to 'remove-broken-file-type-detection-test and delete
another test that is broken due to our `file' package.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 6e8363d819..e8924992f0 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
@@ -87,11 +87,12 @@
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
-                  ;; This test is broken because our `file` package has a
-                  ;; bug in berkeley-db file type detection.
-                  (add-after 'unpack 'remove-berkeley-test
+                  ;; These tests are broken because our `file` package has a
+                  ;; bug in berkeley-db and wasm file type detection.
+                  (add-after 'unpack 'remove-broken-file-type-detection-test
                     (lambda _
-                      (delete-file "tests/comparators/test_berkeley_db.py")))
+                      (delete-file "tests/comparators/test_berkeley_db.py")
+                      (delete-file "tests/comparators/test_wasm.py")))
                   (add-after 'unpack 'embed-tool-references
                     (lambda* (#:key inputs #:allow-other-keys)
                       (substitute* "diffoscope/comparators/utils/compare.py"