summary refs log tree commit diff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2019-09-19 16:43:47 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-09-19 16:45:34 -0700
commit68620d62f5cd49d6455c351f3a68e3c41dc6ce22 (patch)
tree19f13c26b5d6ff895075fc7c21cb52b1234ed947 /gnu/packages/diffoscope.scm
parentb7f1a1aafd806fadee068a026964cde6521a5315 (diff)
downloadguix-68620d62f5cd49d6455c351f3a68e3c41dc6ce22.tar.gz
gnu: Add enjarify.
* gnu/packages/android (enjarify): New variable.
* gnu/packages/diffoscope (diffoscope)[native-inputs]: Add enjarify.
  [arguments]: add enjarify to add-known-tools phase.
* gnu/packages/patches/enjarify-setup-py.patch: New file.
* gnu/local.mk: Add enjarify-setup-py.patch.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index fff331ac13..8df5a9cc0e 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -93,6 +93,9 @@
                     (add-after 'unpack 'add-known-tools
                       (lambda _
                         (substitute* "diffoscope/external_tools.py"
+                          (("'arch': 'enjarify'},")
+                           "'arch': 'enjarify', 'guix': 'enjarify'},"))
+                        (substitute* "diffoscope/external_tools.py"
                           (("'arch': 'python-jsbeautifier'},")
                            "'arch': 'python-jsbeautifier', 'guix': 'python-jsbeautifier'},"))
                         (substitute* "diffoscope/external_tools.py"
@@ -172,6 +175,7 @@
                        ("docx2txt" ,docx2txt)
                        ("dtc" ,dtc)
                        ("e2fsprogs" ,e2fsprogs)
+                       ("enjarify" ,enjarify)
                        ("ffmpeg" ,ffmpeg)
                        ("gettext" ,gettext-minimal)
                        ("ghc" ,ghc)