summary refs log tree commit diff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2021-02-12 15:53:45 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-02-12 16:13:07 -0800
commitd588cc8fa96e4a4bce56fac2ba3bbaaeaaed0047 (patch)
tree63da3320590863608d59e60e1c1b880456e9a42e /gnu/packages/diffoscope.scm
parente69f2e9add408156b6b6e20cda0307037c51b674 (diff)
downloadguix-d588cc8fa96e4a4bce56fac2ba3bbaaeaaed0047.tar.gz
gnu: diffoscope: Update to use python-magic.
Fixes: https://salsa.debian.org/reproducible-builds/diffoscope/-/issues/238

* gnu/packages/patches/diffoscope-revert-to-magic-open.patch: Remove file.
* gnu/local.mk [dist_patch_DATA]: Update.
* gnu/packages/diffoscope.scm (diffoscope)[source]: Remove patch.
  [inputs]: Remove python-file.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index a31ac485c2..feb0324db2 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -81,9 +81,7 @@
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0vc4a38ii6b10af4c7cxfkvj4lk4ihx1xs4q5lshnkyg74gmm21b"))
-              (patches (search-patches
-                        "diffoscope-revert-to-magic-open.patch"))))
+                "0vc4a38ii6b10af4c7cxfkvj4lk4ihx1xs4q5lshnkyg74gmm21b"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -137,7 +135,6 @@
                         (install-file "doc/diffoscope.1" man)
                         #t))))))
     (inputs `(("rpm" ,rpm)              ;for rpm-python
-              ("python-file" ,python-file)
               ("python-debian" ,python-debian)
               ("python-libarchive-c" ,python-libarchive-c)
               ("python-magic" ,python-magic)