summary refs log tree commit diff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2019-09-08 15:35:33 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-09-18 17:26:36 -0700
commit3244b64f708a5b3161bfada2043718c004f199a4 (patch)
tree56f6e92cce2406cc2a4c9ff5e34a3a6a99f88d50 /gnu/packages/diffoscope.scm
parent52211add0b125be7e8a00bea2b3b030286109022 (diff)
downloadguix-3244b64f708a5b3161bfada2043718c004f199a4.tar.gz
gnu: diffoscope: Add additional test dependencies.
* gnu/packages/diffoscope (diffoscope)[native-inputs]: Add abootimg, dtc,
  and r-minimal.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 6eb5c1d9fe..828e06a818 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -25,8 +25,10 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages acl)
   #:use-module (gnu packages admin)
+  #:use-module (gnu packages android)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bootloaders)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -50,6 +52,7 @@
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages ssh)
+  #:use-module (gnu packages statistics)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages video)
   #:use-module (gnu packages vim)
@@ -137,6 +140,7 @@
       (native-inputs `(("python-pytest" ,python-pytest)
                        ("python-chardet" ,python-chardet)
                        ;; test suite skips tests when tool is missing
+                       ("abootimg" ,abootimg)
                        ("bdb" ,bdb)
                        ("binutils" ,binutils)
                        ("bzip2" ,bzip2)
@@ -144,6 +148,7 @@
                        ("colord" ,colord)
                        ("cpio" ,cpio)
                        ("docx2txt" ,docx2txt)
+                       ("dtc" ,dtc)
                        ("e2fsprogs" ,e2fsprogs)
                        ("ffmpeg" ,ffmpeg)
                        ("gettext" ,gettext-minimal)
@@ -163,6 +168,7 @@
                        ("openssh" ,openssh)
                        ("pgpdump" ,pgpdump)
                        ("poppler" ,poppler)
+                       ("r-minimal" ,r-minimal)
                        ("rpm" ,rpm)
                        ("sng" ,sng)
                        ("sqlite" ,sqlite)