summary refs log tree commit diff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2019-10-16 18:18:00 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-10-16 18:23:26 -0700
commitc3704ecaa537f96dfca2f820c3af5357a6208ce6 (patch)
tree07980261c8993c3479cf7c0ecb7aa4154efd73a2 /gnu/packages/diffoscope.scm
parent837b3c5d69456ddff4fda4b781a0c3924a462b5c (diff)
downloadguix-c3704ecaa537f96dfca2f820c3af5357a6208ce6.tar.gz
gnu: diffoscope: Update to 126.
* gnu/packages/diffoscope (diffoscope): Update to 126.
  [arguments]: Remove add-known-tools phase, merged upstream.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 15d5a5787e..23acf0aeb8 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -67,7 +67,7 @@
   #:use-module (ice-9 match))
 
 (define-public diffoscope
-  (let ((version "125"))
+  (let ((version "126"))
     (package
       (name "diffoscope")
       (version version)
@@ -79,7 +79,7 @@
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "02kwisp9j63w27hhcwpdhg66dgxzz61q4fcyfz8z4hwlz6r0gyqy"))))
+                  "0lmn2116g5l05nns8qd2kwsnnd144zrqhs53fsr88inzf0mkqwhj"))))
       (build-system python-build-system)
       (arguments
        `(#:phases (modify-phases %standard-phases
@@ -90,18 +90,6 @@
                       (lambda _
                         (substitute* "setup.py"
                           (("'python-magic',") ""))))
-                    ;; Patch in support for known tools
-                    (add-after 'unpack 'add-known-tools
-                      (lambda _
-                        (substitute* "diffoscope/external_tools.py"
-                          (("'arch': 'enjarify'},")
-                           "'arch': 'enjarify', 'guix': 'enjarify'},"))
-                        (substitute* "diffoscope/external_tools.py"
-                          (("'arch': 'python-jsbeautifier'},")
-                           "'arch': 'python-jsbeautifier', 'guix': 'python-jsbeautifier'},"))
-                        (substitute* "diffoscope/external_tools.py"
-                          (("'arch': 'wabt'},")
-                           "'arch': 'wabt', 'guix': 'wabt'},"))))
                     ;; This test is broken because our `file` package has a
                     ;; bug in berkeley-db file type detection.
                     (add-after 'unpack 'remove-berkeley-test