summary refs log tree commit diff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-10 21:10:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-10 22:12:02 +0200
commit1f033795e25f177bb52efe8e98aee7001ba8ccd0 (patch)
tree75fa13a21734826c6563d5978547ada6ce2012ec /gnu/packages/disk.scm
parent4273a7ef65ce3b89b592093e2a07ecb5a9081d7a (diff)
downloadguix-1f033795e25f177bb52efe8e98aee7001ba8ccd0.tar.gz
gnu: ndctl: Update to 63.
* gnu/packages/disk.scm (ndctl): Update to 63.
[source]: Use GIT-FILE-NAME.
[native-inputs]: Add bash-completion.
[arguments]: Add '--disable-asciidoctor' and '--without-systemd'
 #:configure-flags.  Don't bother patching unused ./autogen.sh in
'patch-FHS-file-names' phase.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 338678b8d1..04fe3deb38 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -600,27 +600,28 @@ passphrases.")
 (define-public ndctl
   (package
     (name "ndctl")
-    (version "61.2")
+    (version "63")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/pmem/ndctl")
+                    (url "https://github.com/pmem/ndctl.git")
                     (commit (string-append "v" version))))
-              (file-name (string-append name "-" version "-checkout"))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0vid78jzhmzh505bpwn8mvlamfhcvl6rlfjc29y4yn7zslpydxl7"))))
+                "060nsza8xic769bxj3pvl70a9885bwrc0myw16l095i3z6w7yzwq"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("asciidoc" ,asciidoc)
        ("automake" ,automake)
        ("autoconf" ,autoconf)
+       ("bash-completion" ,bash-completion)
        ("docbook-xsl" ,docbook-xsl)
        ("libtool" ,libtool)
        ("libxml2" ,libxml2)
        ("pkg-config" ,pkg-config)
        ("xmlto" ,xmlto)
-       ;; Required for offline docbook generation:
+       ;; Required for offline docbook generation.
        ("which" ,which)))
     (inputs
      `(("eudev" ,eudev)
@@ -628,12 +629,13 @@ passphrases.")
        ("kmod" ,kmod)
        ("util-linux" ,util-linux)))
     (arguments
-     `(#:phases
+     `(#:configure-flags
+       (list "--disable-asciidoctor"    ; use docbook-xsl instead
+             "--without-systemd")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-FHS-file-names
            (lambda _
-             (substitute* "autogen.sh"
-               (("/bin/sh") (which "sh")))
              (substitute* "git-version-gen"
                (("/bin/sh") (which "sh")))
              (substitute* "git-version"