summary refs log tree commit diff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-05-12 16:38:56 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-05-13 09:59:08 +0200
commit4fe0c128e90b83b4c3a05e6ee1a8b4a21ab7ac33 (patch)
tree925a845d82568b8b9e61de719baf347c8ea45e50 /gnu/packages/disk.scm
parentb2d7d900750d77ff111d99529d4fae242275abc1 (diff)
downloadguix-4fe0c128e90b83b4c3a05e6ee1a8b4a21ab7ac33.tar.gz
gnu: Add bmaptools.
* gnu/packages/disk.scm (bmaptools): New variable.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 652bb22f21..66d5022cf0 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -19,6 +19,7 @@
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;; Copyright © 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1253,3 +1254,39 @@ and a partitioning of the heap between kinds of memory (for NUMA).")
       (description "mmc-utils is a command-line tool for configuring and
 inspecting MMC storage devices from userspace.")
       (license license:gpl2))))
+
+(define-public bmaptools
+  (package
+    (name "bmaptools")
+    (version "3.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/intel/bmap-tools")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01xzrv5nvd2nvj91lz4x9s91y9825j9pj96z0ap6yvy3w2dgvkkl"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             ;; XXX: Remove failing test.
+             (invoke "nosetests" "-v"
+                     "--exclude" "test_bmap_helpers"))))))
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-nose" ,python-nose)))
+    (propagated-inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://github.com/intel/bmap-tools")
+    (synopsis "Create block map for a file or copy a file using block map")
+    (description "Bmaptool is a tool for creating the block map (bmap) for a
+file and copying files using the block map.  The idea is that large files,
+like raw system image files, can be copied or flashed a lot faster and more
+reliably with @code{bmaptool} than with traditional tools, like @code{dd} or
+@code{cp}.")
+    (license license:gpl2)))