summary refs log tree commit diff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2016-06-16 23:58:45 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-13 00:32:21 +0200
commitabba1d087e296042a8a337e86af84794b449e303 (patch)
tree749e532bed33a10fc7ac9dc866d233a2b46372f0 /gnu/packages/disk.scm
parentbdff55eac313016b9de6605f52528909f73b0db3 (diff)
downloadguix-abba1d087e296042a8a337e86af84794b449e303.tar.gz
gnu: Add gptfdisk.
* gnu/packages/disk.scm (gptfdisk): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index c60eacb15e..83ba4e4f7c 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Tobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,9 +26,12 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages popt)
   #:use-module (gnu packages python)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages guile)
@@ -97,6 +101,46 @@ fdisk.  fdisk is used for the creation and manipulation of disk partition
 tables, and it understands a variety of different formats.")
     (license gpl3+)))
 
+(define-public gptfdisk
+  (package
+    (name "gptfdisk")
+    (version "1.0.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://sourceforge/gptfdisk/gptfdisk/"
+                          version "/" name "-" version ".tar.gz"))
+      (sha256
+       (base32
+        "1izazbyv5n2d81qdym77i8mg9m870hiydmq4d0s51npx5vp8lk46"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("gettext" ,gnu-gettext)
+       ("ncurses" ,ncurses)
+       ("popt" ,popt)
+       ("util-linux" ,util-linux))) ; libuuid
+    (arguments
+     `(#:test-target "test"
+       #:phases
+       (modify-phases %standard-phases
+         ;; no configure script
+         (delete 'configure)
+         ;; no install target
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+               (install-file "gdisk" bin)
+               (install-file "sgdisk" bin)
+               (install-file "cgdisk" bin)
+               (install-file "fixparts" bin)))))))
+    (home-page "http://www.rodsbooks.com/gdisk/")
+    (synopsis "Low-level GPT disk partitioning and formatting")
+    (description "GPT fdisk (aka gdisk) is a text-mode partitioning tool that
+works on Globally Unique Identifier (GUID) Partition Table (GPT) disks, rather
+than on the more common (through 2009) Master Boot Record (MBR) partition
+tables.")
+    (license gpl2)))
+
 (define-public ddrescue
   (package
     (name "ddrescue")