summary refs log tree commit diff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-17 16:58:42 +0100
committerMarius Bakke <marius@gnu.org>2021-12-17 19:07:18 +0100
commit7d2550c3ffecf1ed45774b9ac1c4ff6bef807c4a (patch)
treea9df3d27f1e03a89b4aba6cb9c5acead3dec17cf /gnu/packages/django.scm
parent76f87b01adc8837e78a3f4f503221d5fdc96be67 (diff)
downloadguix-7d2550c3ffecf1ed45774b9ac1c4ff6bef807c4a.tar.gz
gnu: python-django-rest-framework: Update to 3.13.1.
* gnu/packages/django.scm (python-djangorestframework): Update to 3.13.1.
[arguments]: Remove obsolete workarounds.  Set TZDIR in check phase.
[native-inputs]: Add TZDATA-FOR-TESTS.
[propagated-inputs]: Add PYTHON-PYTZ.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index ddb71aebbd..2c9fdab6ad 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1014,7 +1014,7 @@ Django projects, which allows association of a number of tags with any
 (define-public python-djangorestframework
   (package
     (name "python-djangorestframework")
-    (version "3.12.4")
+    (version "3.13.1")
     (source
      (origin
        (method git-fetch)
@@ -1024,26 +1024,22 @@ Django projects, which allows association of a number of tags with any
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "16n17dw35wqv47m8k8fixn0yywrvd6v4r573yr4nx6lbbiyi2cqn"))))
+         "11wfb156yin6mlgcdzfmi267jsq1cld131mxgd13aqsrj06zlray"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             ;; Add a fix from the master branch for compatibility with Django
-             ;; 3.2: https://github.com/encode/django-rest-framework/pull/7911
-             ;; Remove for versions > 3.12.4.
-             (substitute* "tests/test_fields.py"
-               (("class MockTimezone:")
-                "class MockTimezone(pytz.BaseTzInfo):"))
+           (lambda* (#:key tests? inputs #:allow-other-keys)
              (if tests?
-                 (invoke "python" "runtests.py" "--nolint")
+                 (begin
+                   (setenv "TZDIR" (search-input-directory inputs "share/zoneinfo"))
+                   (invoke "python" "runtests.py"))
                  (format #t "test suite not run~%")))))))
     (native-inputs
-     (list python-pytest python-pytest-django))
+     (list python-pytest python-pytest-django tzdata-for-tests))
     (propagated-inputs
-     (list python-django))
+     (list python-django python-pytz))
     (home-page "https://www.django-rest-framework.org")
     (synopsis "Toolkit for building Web APIs with Django")
     (description