summary refs log tree commit diff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 14:17:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 15:30:08 +0300
commitba1c2e5b0d698ce6849f63af867d68cb1f8242b5 (patch)
tree202cd938b7a57363eb8621cf9f18a729b6cb06e1 /gnu/packages/django.scm
parent1c24d6d6629ec3096b8bd64176b5e063b2692fdb (diff)
downloadguix-ba1c2e5b0d698ce6849f63af867d68cb1f8242b5.tar.gz
gnu: python-django-testing: Fix tests.
* gnu/packages/django.scm (python-django-tagging)[arguments]: Use custom
'check phase.
[inputs]: Add python-django.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 7c89757082..ce23946c90 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1089,6 +1089,15 @@ higher quality while welcoming newcomers.")
         (base32
          "0s7b4v45j783yaxs7rni10k24san0ya77nqz4s7zdf3jhfpk42r1"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (setenv "DJANGO_SETTINGS_MODULE" "tagging.tests.settings")
+             (invoke "django-admin" "test" "--pythonpath=."))))))
+    (inputs
+     `(("python-django" ,python-django)))
     (home-page "https://github.com/Fantomas42/django-tagging")
     (synopsis "Generic tagging application for Django")
     (description "This package provides a generic tagging application for