summary refs log tree commit diff
path: root/gnu/packages/djvu.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-11-26 09:37:34 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-11-26 09:37:34 +0100
commit446ec88a4021e1fadc34a6e4c29d6c8105c841b2 (patch)
tree567cbcf49aeec03fe6108eee40e720d7104daee9 /gnu/packages/djvu.scm
parent824a9f1060111d9ab2317b1453360e39eda8201a (diff)
downloadguix-446ec88a4021e1fadc34a6e4c29d6c8105c841b2.tar.gz
gnu: djvusmooth: Fix path to djvused.
* gnu/packages/djvu.scm (djvusmooth)[arguments]: Add 'fix-paths' phase.
Diffstat (limited to 'gnu/packages/djvu.scm')
-rw-r--r--gnu/packages/djvu.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/djvu.scm b/gnu/packages/djvu.scm
index 605a922768..e68231a3c5 100644
--- a/gnu/packages/djvu.scm
+++ b/gnu/packages/djvu.scm
@@ -295,7 +295,16 @@ and white.")
        ("python2-subprocess32" ,python2-subprocess32)
        ("python2-wxpython" ,python2-wxpython)))
     (arguments
-     `(#:python ,python-2))
+     `(#:python ,python-2
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "lib/djvused.py"
+               (("djvused_path = 'djvused'")
+                (string-append "djvused_path = '"
+                               (assoc-ref inputs "djvulibre")
+                               "/bin/djvused'"))))))))
     (synopsis "Graphical editor for DjVu documents")
     (description
      "@code{djvusmooth} is a graphical editor for DjVu_ documents.