summary refs log tree commit diff
path: root/gnu/packages/djvu.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:33:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:26 -0400
commitd9e54dfd4c60791b923ae309e1fb0ac635502c01 (patch)
tree23227eb25fecbb435210c88136f33542d6ac8b9d /gnu/packages/djvu.scm
parent9384d5de3c72d7d362c272b229ec951845160552 (diff)
downloadguix-d9e54dfd4c60791b923ae309e1fb0ac635502c01.tar.gz
gnu: Remove djvusmooth.
* gnu/packages/djvu.scm (djvusmooth): Delete variable.
Diffstat (limited to 'gnu/packages/djvu.scm')
-rw-r--r--gnu/packages/djvu.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/djvu.scm b/gnu/packages/djvu.scm
index 0fc2f6dfb9..9c834bcfba 100644
--- a/gnu/packages/djvu.scm
+++ b/gnu/packages/djvu.scm
@@ -291,46 +291,6 @@ and white.")
     (home-page "https://sourceforge.net/projects/minidjvu/")
     (license license:gpl2)))
 
-(define-public djvusmooth
-  (package
-    (name "djvusmooth")
-    (version "0.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/jwilk/djvusmooth/releases/download/" version
-             "/djvusmooth-" version ".tar.gz"))
-       (sha256
-        (base32 "0z403cklvxzz0qaczgv83ax0nknrd9h8micp04j9kjfdxk2sgval"))))
-    (build-system python-build-system)
-    (inputs
-     (list djvulibre python2-djvulibre python2-subprocess32
-           python2-wxpython))
-    (arguments
-     `(#:python ,python-2
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-paths
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "lib/djvused.py"
-               (("djvused_path = 'djvused'")
-                (string-append "djvused_path = '"
-                               (assoc-ref inputs "djvulibre")
-                               "/bin/djvused'"))))))))
-    (synopsis "Graphical editor for DjVu documents")
-    (description
-     "@code{djvusmooth} is a graphical editor for DjVu_ documents.
-It is able to:
-@itemize
-@item edit document metadata,
-@item edit document outline (bookmarks),
-@item add, remove or edit hyperlinks,
-@item correct occasional errors in the hidden text layer.
-@end itemize\n")
-    (home-page "https://jwilk.net/software/djvusmooth")
-    (license license:gpl2)))
-
 (define-public didjvu
   (package
     (name "didjvu")