summary refs log tree commit diff
path: root/gnu/packages/djvu.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-10 00:33:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-10 04:37:22 +0200
commite6c2a88f3d9717be183a0346766cd65d10a904f4 (patch)
tree886f1107edf32952b2c62e95716c10245c5ddec9 /gnu/packages/djvu.scm
parent2971ed57345ee4e00058efeaf27c6a0790fdc9dd (diff)
downloadguix-e6c2a88f3d9717be183a0346766cd65d10a904f4.tar.gz
gnu: djview: Update to 4.11.
* gnu/packages/djvu.scm (djview): Update to 4.11.
[source]: Use GIT-FETCH and add a FILE-NAME.
[native-inputs]: Add autoconf, automake, and libtool.
[arguments]: Add a ‘make-files-writable’ phase.
Diffstat (limited to 'gnu/packages/djvu.scm')
-rw-r--r--gnu/packages/djvu.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/djvu.scm b/gnu/packages/djvu.scm
index 1fb5b5267e..f5ea9bd332 100644
--- a/gnu/packages/djvu.scm
+++ b/gnu/packages/djvu.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,7 +23,9 @@
   #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages image)
   #:use-module (gnu packages pkg-config)
@@ -59,18 +62,22 @@ utilities.")
 (define-public djview
   (package
     (name "djview")
-    (version "4.10.6")
+    (version "4.11")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "mirror://sourceforge/djvu/DjView/"
-                           (version-major+minor version) "/"
-                           "djview-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.code.sf.net/p/djvu/djview-git")
+             (commit (string-append "release." version))))
        (sha256
-        (base32 "08bwv8ppdzhryfcnifgzgdilb12jcnivl4ig6hd44f12d76z6il4"))))
+        (base32 "0qlhd0xlxn8i869m0hwdjvwivi2vigqm88wliyr1h7s84zl3qhsy"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)
        ("qttools" ,qttools)))
     (inputs
      `(("djvulibre" ,djvulibre)
@@ -86,6 +93,11 @@ utilities.")
            (lambda _
              (substitute* "desktopfiles/djvulibre-djview4.desktop"
                (("Exec=djview4 %f") "Exec=djview %f"))
+             #t))
+         (add-after 'unpack 'make-files-writable
+           (lambda _
+             (for-each make-file-writable
+                       (find-files "."))
              #t)))))
     (home-page "http://djvu.sourceforge.net/djview4.html")
     (synopsis "Viewer for the DjVu image format")